Сorporate news
21 May 2012, 14:15

From June 1, 2012, the Support of Client Terminal Below 416 Build will be Stopped.

Dear Customers!

We remind you that from June 1, 2012, the support of client terminal below 416 build will be stopped (disabling hacked network MetaTrader 4 protocols ). Therefore, we kindly ask you: make sure once again that you are using the latest version of the trading terminal. You can download the latest version at TeleTrade website.

Since June 1, 2012, the terminals below 416 build will not be able to connect to the trading server: it will not be possible to get updates and trade. The only solution for traders with the old builds of terminals will be the download of latest version of distribution and reinstalling the terminal.

© 2000-2022. All rights reserved.

This site is managed by Teletrade D.J. Limited 20599 IBC 2012 (First Floor, First St. Vincent Bank Ltd Building, James Street, Kingstown, St. Vincent and the Grenadines).

The information on this website is for informational purposes only and does not constitute any investment advice.

AML Website Summary

Risk Disclosure

Making transactions on financial markets with marginal financial instruments opens up wide possibilities and allows investors who are willing to take risks to earn high profits, carrying a potentially high risk of losses at the same time. Therefore you should responsibly approach the issue of choosing the appropriate investment strategy, taking the available resources into account, before starting trading.

Privacy Policy

Use of the information: full or partial use of materials from this website must always be referenced to TeleTrade as the source of information. Use of the materials on the Internet must be accompanied by a hyperlink to teletrade.org. Automatic import of materials and information from this website is prohibited.

Please contact our PR department if you have any questions or need assistance at pr@teletrade.global.

Feedback
Live Chat E-mail
Up
Choose your language / location